ARCVIEW as a GIS tool.

The purpose of ARCVIEW, its Components and Terminology.

ARCVIEW is a user-friendly tool which allows viewing and analyzing spatial information. Using ARCVIEW, the user can view spatial data, do spatial analysis, create maps and build his/her own customized applications through AVENUE, the ARCVIEW programming language.

To start the ARCVIEW software, type ‘arcview’ at the prompt within a command tool or ask the system administrator for the right command.

The picture shows the main ARCVIEW interface - PROJECT and its components
“Views” is an interface to view GIS data. View consists of the canvas and different tool that allow user to display data and perform spatial iterations;

“Tables” is an interface to create or add new tables to the projects. Tables can be attribute tables of the GIS data or tables created with Excel or Lotus, “.dbf” format or “text, comma-delimited”;

“Charts” is an interface to create charts using data from tables;

“Layouts” is an interface to make actual maps using “Views”;

“Scripts” is an interface to create customized scripts for ARCVIEW using AVENUE language;
Views, Themes, and the Legend Editor

Start Arcview.

Under the File menu, select Save Project and save views.apr in your home directory. Fill most of the monitor screen with the ArcView window.

The Project

- highest organizational unit of ArcView (discussed in the previous session)
- stored as an ASCII file and does not contain the data you are working with, but instead is a link between the two
- dynamic link because any changes made to the data referenced in the Project will be automatically reflected in the Project when it is reopened
- all Project files have an .apr extension and stored as an ASCII text files.

Check the Properties under the Project menu and check the Working Directory. It is probably set to $HOME, which is the default, this is a variable set in the system files and is equal to the directory where your account resides, i.e. for example: /usr/manhattan/gis_class/<user account name>. This is where all of your ArcView files are saved.

1 Views

a. To add a new View to the Project, click on the View icon, select New - or - double click the View icon. A Project can have many Views, all being independent of one another. The default name of this View is ‘view1’.

b. When a new View is opened, note it’s name appearing in both the project management window and at the top of the View window.

c. To change the properties of the View, select Properties from the View menu. In the View Properties window you will see that ‘unknown’ appears for both the Map units and Distance units.

- Change the name of the View to ‘Training View’.
- Map units refers to the units in which the geographic data are stored, in our case this will be meters.
- Distance units refers to the units of length or area displayed when drawing graphic features in the View or when measurements are made. Set this to feet.
- Click ‘OK’
NOTE:
The name of the View has changed from ‘view1’ to ‘Training View’. Most of the menus, buttons and tools are inactive (shaded gray). This is because most of these options require Themes to be present in the View for their functionality.

When you drag the cursor over one of the tools or buttons a brief description of it’s function will appear at the bottom left corner of the project window.

2 Themes

The building block of the View is the Theme. These Themes represent any spatial data set, that is, any features with locational attributes. Data sources which can be represented as Themes:

1. ArcInfo coverages and ArcView shapefiles
   - vector data, coordinates stored as points, lines or polygons. ex. ArcInfo coverages, ArcView shape files

2. Images, Grid data
   - raster data, an area divided into rows and columns creating a matrix of cells with values assigned to each cell. ex. satellite images, ArcInfo grid coverages.

3. Tables with fields containing locational data (ex. latitude, longitude). ex. ASCII text files, dBase tables, global positioning system files (exported as shapefiles).

Adding Themes to the View

A. ArcInfo Coverages and ArcView shape files.

STEPS:

1. There are two ways of adding a Theme to a View: Click INSERT THEME from the button bar or click ADD THEME from the View menu. A menu box titled ‘ADD THEME’ will appear which will allow you to scroll through the storage disks and select a data set.

NOTE:
When adding a Theme to a View you will see an icon appearing to the left of each Theme name (see below) in the Add Theme dialog box. If this icon has a folder behind it then the Theme (i.e. ArcInfo coverage) contains multiple feature classes (polygon, arc, labelpoint, etc.). If you single click on this icon a list of the available feature classes for that Theme will appear. Double click the feature class you would like to add as a theme.
2. In the right scroll window double click through to /usr/manhattan/gis_class/yxg/data/ and notice that several selections will appear in the left scroll window.

3. Click on basin24eoh and click ‘OK’ - or - double click basin24eoh.

NOTE:
The Theme basin24eoh appears in the legend window of ‘Training View’ with a name and a randomly chosen display color, but does not display in the View’s graphics window.

Most of the menus, buttons and tools have now become active. This is because a Theme has been added to ‘Training View’ and operations can be performed on it.

4. To display the Theme you need to click the check box which appears just to the left of the Theme’s name. This theme is the East of Hudson District reservoir and control lake basins.

B. Images

STEPS:

1. Repeat steps 1 and 2 from above, but go to /usr/manhattan/gis_class/yxg/data/ instead. Notice that no selections appear in the left scroll box. This is because Data Source Types: in the lower left corner of the ADD THEME window (see above) is set on Feature Data Source (ie. ArcInfo coverages).

2. Click on the inverted triangle to the right of Feature Data Source and select Image Data Source. Several titles appear in the left scroll box with a .tif extension, these are the images.

3. Scroll down through this window and double click plan56.tif or select it and click OK.

4. Click the check box next to the Theme name to display the planimetric image of the Lake Carmel USGS quadrangle.

NOTE:
When plan56.tif was added to the View Table of Contents many of the menu, button and tool choices became inactive. This is because plan56.tif is a scanned document and while these images represent features on the ground, they do not contain attributes about those features which are necessary for many of the View functions.

When plan56.tif is displayed, you will notice that it’s name and the check box in the Table of Contents became ‘raised’ or active. Now click on the basin24eoh Theme below it and
activate this one. Many of the functions above again become active because the `basin24eoh` theme contains attributes.

C. Adding Tabular Data as a Theme

Menu        Add Event Theme - will be discussed in a later session
It is possible to display tables which contain georeferenced data (i.e. with x and y coordinate fields).

NOTE: These tables must have column headings in order for the above function to work.

Now add two more themes:
/usr/manhattan/gis_class/yxg/data/eoh24road - and -
/usr/manhattan/gis_class/yxg/data/stp
..... and check their display boxes.

Add /usr/manhattan/gis_class/yxg/data/lu1991put (Putnam Co. land use) but **do not** check the display box.

D. Table of Contents

The Themes in the Table of Contents are drawn in reverse order in which they are listed. The last theme is drawn first (on the bottom) and the first is last (on the top). Only those Themes with a check mark will be drawn. This order can be modified.

STEPS:

1. Click on the `stp` theme in the Table of Contents with the left mouse key and while holding it down drag the Theme to the bottom of the list. The theme’s features are no longer visible because they were redisplayed below the theme above it.

2. Return the stp theme to it’s original location.

3. Click on the `plan56.tif` image theme and while holding the select key down drag it to the bottom of the list.

E. Tools

1. Zooming Features

a. Click the Zoom In tool. Move the cursor anywhere over the view display window and click with left mouse button and while holding the left mouse button down drag the cursor to the oppo-
site corner of the area of interest. Release the mouse button. -OR- Click once over an area of interest.

b. Click the Pan tool. Click the left mouse button in the view display window and while holding it down, drag the pointer in the direction you would like the display to move.

c. Click the Zoom Out tool. Move the cursor over an area in the View and click. The View will be redrawn at a smaller scale with the location where you clicked in the center of the View.

2. Other Features

a. Click on the Identify tool. Before using this tool be sure to ‘activate’ the Theme or Themes in the Table of Contents from which you would like to find out information. Start clicking on features and an Identify Results window will appear which lists all of the available data about that feature. To activate more that one theme, hold the shift key down while selecting Themes from the Table of Contents.

b. Click the Label Features tool and activate only the stp theme, now click on any stp and the name of the plant will appear on top of it.

c. Click the Select tool which allows you to select text and shapes, and place it over the stp name which just appeared in the View, click and hold the mouse button down and drag the text element to a new location.

d. Click the far right tool with the mouse button and hold it down. You will notice several drawing options. Drag the pointer down and select the straight line tool and draw a line under the plant name by holding down the mouse key and dragging a line segment, release the mouse key when you have finished the line.
EEE 1001 Introduction to GIS technology for visualization and analysis of environmental data.

e. When the View is active and a theme is active in the View, this tool selects one or more features. Hold [Shift] key down to add to your selection, or remove from your selection:

![Selection Tool](image)

**GRAPHIC CONTROL:**

1. Point
2. Line
3. Multi-segment line
4. Circle
5. Box
6. Polygon

**NOTE:**

There are six choices under the **Edit menu** which allow you to manipulate the graphical elements of the View. Select both the name and the line with the Select tool (use the shift key) and choose Delete Graphics from the Edit menu.

You can also label the features of a Theme by choosing Auto Label from the Theme menu. This option will label the **selected** features of any **active** themes.

e. Click the Measure tool. This allows you to measure distances between objects and will display the results along the bottom of the Project window in units defined in the Distance units box in the View Properties dialogue box, feet in this case (Part 1, step c.). Double click the measuring cursor on the View window to end the measured segment.

![Measure Tool](image)

**F. Buttons**

1. **Edit Theme Properties**

   a. Activate the **basin24eoh** theme and click the Zoom to Extent of Active Themes button.

   ![Zoom toExtent](image)

   b. Activate the **stp** theme and click the Edit Theme Properties button. A window appears which displays the theme name, it's source, a query builder and a com-

   ![Edit Theme Properties](image)
EEE 1001 Introduction to GIS technology for visualization and analysis of environmental data.

ments field. The query builder will be discussed in a later session.

c. Change the **Theme Name** to ‘Sewage Treatment Plants’.

d. Click the Text Labels icon and under the Label Field, scroll down and select Permit#. No position the text relative to the label point, choose the upper middle position.

e. Click the Display icon which will allow you to choose the Minimum and Maximum Scale. Key in 100000 for a Maximum Scale, click OK. Notice when the View window is redraw that ‘Sewage Treatment Plants’ has replaced stp in the Table of Contents and the stp’s have not redrawn.

NOTE:
The scale just above the View window should read approximately 1:300000, with these new settings Sewage Treatment Plants will not be redrawn until this ratio is 1:100000 or less.

f. Replace the scale number above the View with 90000. Stp’s will be redrawn.

g. Activate the **stp** theme, select the Label Features tool and click on an stp. The plant’s permit number has been displayed directly above the point (what we specified in the Theme Properties).

2.3 Legend Editor

a. From the Table of Contents activate the lu1991put theme (do not check the draw box) and shift-click the basin24eoh theme.
b. Click on the Display Legend of Active Themes button and click the inverted triangle next to Theme: in the Legend Editor. Both active themes should be listed. Choose lu1991put.

NOTE: The Legend of a Theme is the link between the fields and values of the source data and the way in which these values are displayed.

c. Click the inverted triangle next to Legend Type: and choose Unique Value. Next, scroll the Value Field: to Descrip-level, this allows you to display the polygons of this theme based on the contents of this field instead of using just one color. Click the ‘Apply’ button, then click the draw box in the Table of Contents.

d. Now try displaying the land use by Area (square meters/polygon). From Legend Type:, select Graduated Color, then choose Area from the Classification Field: and click the Classify button.

e. DONT FORGET TO APPLY CHANGES
UNDO will consecutively undo the past legend edits to a theme.

f. Under Theme: in the Legend Editor select basin24eh.

g. Double click the shade symbol box in the Legend Editor or select Show Symbol Palette from the Window menu and the Palette window will appear. This allows you to modify the display of any Theme and its associated graphics.

There are six palette choices:

1. Fill - polygon fill patterns
2. Pen - line symbols
3. Marker - symbols available for points locations
4. Font - selecting and sizing fonts for labels
5. Color - selecting the colors for polygon fill, lines, points and text.
6. Manager - allows you to customize the other palettes by adding your own symbols, manipulate the existing ones save them and remove the existing symbols.

h. Choose the Color Palette if it does not already appear. This is the paint brush icon.
The symbol is presently set to a solid shade with black border around the polygons. Notice that the ‘Color: Outline’ is highlighted on black. Click the red box.

Again in the Color Palette under Color:, select Foreground and click on the transparent color box (upper left) and click Apply in the Legend Editor. Notice the View display window. Now you should see the planimetric image with all other features on top of it.

Now double click the **Sewage Treatment Plants** theme name in the Table of Contents and notice that the name now appears in the Legend Editor. Double click the point symbol and an array of point symbols will appear in the Marker Palette window.

Chose a new symbol, change the Size to 12 and select Apply in the Legend Editor.

### 3. Other Zooming Features:

**NOTE:**

These buttons allow you to zoom to ‘extents’ of active themes. Picture the extent of a theme as being a box which encompasses all of the features of that particular theme

a. Click the Zoom to Extent of All Themes button.

b. Activate **plan56.tif** in the Table of Contents and click the Zoom to the Extent of Active Themes button.

c. The button the right, Zoom to the Extent of Selected Features will be discussed in a later session. The two zoom buttons to the right of this will zoom in or out from the center of the display.

### G. Theme Menu Choices

a. Properties - already discussed.

b. Stop/Start/Save Editing - refers to shape files which will be covered in a later session.
c. Convert to Shapefile - discussed in a later session also.

d. Edit Legend - already discussed (Button choice).

e. Hide/Show Legend - refers to the legend in the View’s Table of Contents. Activate lu1991put in the Table of Contents and select this function, then select it again. Observer the Table of Contents. It is simply a space saver in the Table of Contents, the Theme will still display and you can still edit it’s legend.

f. Auto-Label - will label all selected features of the active theme with the value of the label field chosen in the Theme Properties. Activate Sewage Treatment Plants and select Auto-Label. All of the stp’s will be labeled with it’s permit#. Under the Edit menu chose Delete Graphics.

Before using auto-label check the font and size in the Palette Manager to see if it is appropriate to labelling the theme’s features at the current scale.

g. Remove Labels - deletes all of the labels for the active theme

h. Remove Overlapping Labels - overlapping labels will be displayed in green

i. Convert Overlapping Labels - this will change the color of the green overlapping labels to that of the rest of the labels of the same theme. First select all of the label elements of a theme by Selecting All Graphics from the Edit menu and choose Convert Overlapping Labels.

NOTE:

Graphical elements must be selected before they can be edited. If there are graphical elements that were not removed with Delete or Cut Graphics menu choice then use either Select All Graphics from the Edit menu or select particular graphics with the Pointer tool, then Delete or Cut from the Edit Menu.

If you double click any text element in the View with the Select tool a Text Properties window will appear allowing you to change the text and various positions. Try this now by
activating basin24eh in the Table of Contents, choosing the Label Features tool and clicking on one of the basins. Now select the Select tool and double click the basin name. Edit the name in the window and click OK. Note its appearance as the name redisplays.

j. Attach Graphics - you can attach selected graphical elements to a Theme, so the graphics inherit the scale properties of the Theme. If the Theme is rescaled, then the graphics are scaled along with it or if the Theme is not redrawn then the graphics also will not be redrawn.

k. Detach Graphics will do the opposite of the above.

l. The four bottom menu choices will be discussed in a later session.

H. Edit Menu

a. Cut / Copy Themes - used for moving and copying themes between views.

b. Combine Graphics - combined a selected set of graphics into a single graphic. For example, two selected polygons overlap, the two are joined and the overlapping portion is removed from the final polygon. Works only on polygon, circle and rectangle graphics. Use the pointer tool to select graphics.

c. Union Graphics - selected graphics form a single graphic. Works on point, line, polygon, circle and rectangle graphics.

d. Subtract Graphics - subtracts areas overlapped by one graphic from the other. The portion of the bottom graphic that is overlapped by the other is removed while the graphic above remains the same. Works only on selected polygon, rectangle and circle graphics.

e. Intersect Graphics - a new polygon is generated from the intersecting area of selected overlapping polygons. Works only on selected polygon, rectangle and circle graphics.

Save changes to views.apr

File ---> Save Project
2.4 Exercise 1


2. Open a second View in the current Project, enlarge it to fit the Project window and make the following changes in the View Properties dialogue window.
   - Change it’s name to ‘reservoirs’
   - Select meters for Map Units
   - Select feet for Distance Units,
   Click OK.

3. Add the following Themes:
   a. /usr/manhattan/gis_class/yxg/data/res24nyc (New York City Reservoirs)
   b. /usr/manhattan/gis_class/yxg/data/subbas24eoh (subbasins)
   c. /usr/manhattan/gis_class/yxg/data/sitelim (Limnological sampling sites)

4. Use the Zoom tools (in, out, pan) to navigate throughout the View.

5. Activate the sitelim theme. Use the Identify tool to determine the names of some of the limnological sampling sites. (Remember that the Theme or Themes must be activated in order to identify features.)

6. Use the Find Features button (below, not case sensitive) to locate limnology sampling site, 4BRK. Measure the distance between 4BRK and reservoir shoreline.

   * The Find Features button will search the entire table associated with the active theme for the first occurrence of your entry and then zoom in on that selection. This button will only work on character fields.

7. Label one of the EOH subbasins and draw a rectangle around the name (Remember the Draw tool which has several drawing options.). Then select the name and box and delete them (remember Delete Graphics from the Edit menu choice).

8. Close the reservoirs view and open ‘Training View’.
Exercise 2:


2. Activate sitelim and open the Theme Properties window.

3. Rename the Theme, “Reservoir Sampling Sites”, change the Label Field by scrolling down to Ag-sitename and click ‘OK’.

4. Zoom to the extent of Reservoir Sampling Sites. Open the Palette Window and select the Font Palette, choose Helvetica with a size of 3. Select Auto-Label from the Theme menu and select the Find Best Placement option and check the Allow Overlapping Labels and Scale Labels boxes. Click ‘OK’. Have any green labels appeared? If so, change them all to the same color.

4. Activate subbas24eoh and res24nyc. Open the Legend Editor, choose subbas24eoh as a THEME, change the LEGEND TYPE to Graduated Color and change the CLASSIFICATION FIELD value to Area and create an Equal Interval classification with 4 classes. (use Classify button in the Legend Editor), click OK and Apply these changes.

5. Under THEME in the Legend Editor window choose res24nyc and double click the colored rectangle and the Palette window will appear. Change this symbol to color cyan with a diagonal line pattern (Fill Palette). Click apply in the Legend Editor.


Save changes to views.apr

   File --->  Save Project
HOMEWORK

View the page: http://pollux.geog.ucsb.edu/~kclarke/g176a.outline.html

Do Lab 0 on this page. Look at as many GIS links as you can. Make a list of questions for discussion and e-mail it to me.

Convert the following map distances to the ground distance:

1:24,000

1 cm = ??? km;
1 inch = ??? miles;

1:250,000

1 cm = ??? km;
1 inch = ??? miles;

Please, convert the following geographic coordinates into decimal degrees:

46° 30’ 00” = ???
-73° 50’ 00” = ???
35° 45’30” = ???